diff mbox series

[bug#50835,v2,04/24] gnu: Add ghc-libxml-sax.

Message ID 20220114024546.75747-4-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-libxml-sax): New variable.
---
 gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index bf1aa68305..71e06e26bd 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16150,3 +16150,28 @@  TCP sockets are the default way to connect to a Redis server.  For connections
 to a server on the same machine, Unix domain sockets offer higher performance
 than the standard TCP connection.")
     (license license:bsd-3)))
+
+(define-public ghc-libxml-sax
+  (package
+    (name "ghc-libxml-sax")
+    (version "0.7.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/libxml-sax/libxml-sax-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32 "0lbdq6lmiyrnzk6gkx09vvp928wj8qnqnqfzy14mfv0drj21f54r"))))
+    (build-system haskell-build-system)
+    (inputs
+      (list
+        ghc-xml-types
+        libxml2))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (home-page "https://hackage.haskell.org/package/libxml-sax")
+    (synopsis "Bindings for the libXML2 SAX interface")
+    (description "LibXML-SAX is a very simple and direct binding to libXML2's
+SAX parser.")
+    (license license:expat)))