diff mbox series

[bug#50835,v2,24/24] gnu: Add ghc-ipld-cid.

Message ID 20220114024546.75747-24-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-ipld-cid): New variable.
---
 gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c27064a327..b1cc01b7d2 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16630,3 +16630,26 @@  https://gist.github.com/maaku/8996338#file-bip-ecc32-mediawiki.")
       "Multibase implements self-identifying base encodings as an implementation
 of https://github.com/multiformats/multihash.")
     (license license:bsd-3)))
+
+(define-public ghc-ipld-cid
+  (package
+    (name "ghc-ipld-cid")
+    (version "0.1.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (hackage-uri "ipld-cid" version))
+        (sha256
+          (base32 "1y08j0ibcrpfcm0zv1h17zdgbl3hm3sjvm0w9bk1lzdipd6p6cwj"))))
+    (build-system haskell-build-system)
+    (inputs
+      (list ghc-binary-varint
+            ghc-cryptonite
+            ghc-hashable
+            ghc-multibase
+            ghc-multihash-cryptonite))
+    (native-inputs (list ghc-hedgehog))
+    (home-page "https://github.com/monadic-xyz/ipfs")
+    (synopsis "IPLD Content-IDentifiers for Hasell")
+    (description "IPLD-CID is an implementation of https://github.com/ipld/cid.")
+    (license license:bsd-3)))