diff mbox series

[bug#50835,v2,02/24] gnu: Add ghc-scanner.

Message ID 20220114024546.75747-2-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-scanner): New variable.
---
 gnu/packages/haskell-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 8260bb7dc4..9670b50a65 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16057,3 +16057,30 @@  data Dec a
 patrickmn/go-cache for Go.  The cache is a shared mutable HashMap implemented
 using STM and with support for expiration times.")
     (license license:bsd-3)))
+
+(define-public ghc-scanner
+  (package
+    (name "ghc-scanner")
+    (version "0.3.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/scanner/scanner-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32 "1mhqh94qra08zidqfsq0gxi83cgflqldnk9rr53haynbgmd5y82k"))))
+    (build-system haskell-build-system)
+    (inputs (list ghc-fail))
+    (native-inputs
+      (list
+        ghc-hspec
+        pkg-config))
+    (home-page "https://github.com/Yuras/scanner")
+    (synopsis
+      "Fast non-backtracking incremental combinator parsing for bytestrings")
+    (description
+      "Scanner is a parser combinator library designed to be fast.
+It doesn't support backtracking.")
+    (license license:bsd-3)))