diff mbox series

[bug#50835,v2,18/24] gnu: Add ghc-cpu.

Message ID 20220114024546.75747-18-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-cpu): New variable.
---
 gnu/packages/haskell-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 26ac5cdb5d..92b3d99b19 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16486,3 +16486,21 @@  IPv6 address should be surrounded by square brackets.")
       "Multihash Cryptonite implements self-identifying hashes as an
 implementation of https://github.com/multiformats/multihash")
     (license license:bsd-3)))
+
+(define-public ghc-cpu
+  (package
+    (name "ghc-cpu")
+    (version "0.1.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (hackage-uri "cpu" version))
+        (sha256
+          (base32 "0x19mlanmkg96h6h1i04w2i631z84y4rbk22ki4zhgsajysgw9sn"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/vincenthz/hs-cpu")
+    (synopsis "CPU information and properties helpers")
+    (description
+      "CPU is a library to get basic lowlevel properties of the cpu platform,
+like endianness and architecture.")
+    (license license:bsd-3)))