diff mbox series

[bug#50835,v2,13/24] gnu: Add ghc-random-shuffle.

Message ID 20220114024546.75747-13-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-random-shuffle): New variable.
---
 gnu/packages/haskell-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 146d5ce2cf..74d6460edf 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16388,3 +16388,23 @@  Does only what it needs to do and nothing more, no XEP wrappers etc.")
     (synopsis "Quick and dirty statsd interface")
     (description "Hstatsd is a statsd interface.")
     (license license:public-domain)))
+
+(define-public ghc-random-shuffle
+  (package
+    (name "ghc-random-shuffle")
+    (version "0.0.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (hackage-uri "random-shuffle" version))
+        (sha256
+          (base32 "0586bnlh0g2isc44jbjvafkcl4yw6lp1db8x6vr0pza0y08l8w2j"))))
+    (build-system haskell-build-system)
+    (inputs (list ghc-random ghc-monadrandom))
+    (home-page "http://hackage.haskell.org/package/random-shuffle")
+    (synopsis "Random shuffle implementation")
+    (description
+      "This library is a random shuffle implementation on immutable lists,
+based on `perfect shuffle' implementation by Oleg Kiselyov
+available at http://okmij.org/ftp/Haskell/perfect-shuffle.txt")
+    (license license:bsd-3)))