diff mbox series

[bug#50835,v2,15/24] gnu: Add ghc-hostandport.

Message ID 20220114024546.75747-15-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-hostandport): New variable.
---
 gnu/packages/haskell-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f7a04e2976..c4fd46fcab 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16429,3 +16429,24 @@  GHC event manager timeouts when available (GHC 7.2+, -threaded, non-Windows OS),
 yielding performance similar to threadDelay and registerDelay.  Otherwise,
 it falls back to forked threads and threadDelay.")
     (license license:bsd-3)))
+
+(define-public ghc-hostandport
+  (package
+    (name "ghc-hostandport")
+    (version "0.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (hackage-uri "HostAndPort" version))
+        (sha256
+          (base32 "1rjv6c7j6fdy6gnn1zr5jnfmiqiamsmjfw9h3bx119giw3sjb9hm"))))
+    (build-system haskell-build-system)
+    (native-inputs
+      (list ghc-hspec ghc-doctest))
+    (home-page "https://github.com/bacher09/hostandport")
+    (synopsis "Parser for host and port pairs like localhost:22")
+    (description
+      "HostAndPort is a simple parser for parsing host and port pairs.
+Host can be either ipv4, ipv6 or domain name and port are optional.
+IPv6 address should be surrounded by square brackets.")
+    (license license:expat)))