diff mbox series

[bug#49327,core-updates,016/128] gnu: engineering: Add 'bash' input for 'wrap-program'.

Message ID 20210702100814.23249-16-maximedevos@telenet.be
State New
Headers show
Series Add 'bash' input for 'wrap-program'. | expand

Commit Message

M July 2, 2021, 10:06 a.m. UTC
It is required for cross-compilation.

* gnu/packages/engineering.scm
  (librecad)[inputs]: Add 'bash-minimal'.
  (pcb)[inputs]: Likewise.
  (kicad)[inputs]: Likewise.
  (volk)[inputs]: Likewise.
  (freehdl)[inputs]: Likewise.
  (freecad)[inputs]: Likewise.
---
 gnu/packages/engineering.scm | 19 +++++++++++++------
 1 file changed, 13 insertions(+), 6 deletions(-)

Comments

Maxim Cournoyer Oct. 20, 2023, 3:02 p.m. UTC | #1
Hi,

Maxime Devos <maximedevos@telenet.be> writes:

> It is required for cross-compilation.
>
> * gnu/packages/engineering.scm
>   (librecad)[inputs]: Add 'bash-minimal'.
>   (pcb)[inputs]: Likewise.
>   (kicad)[inputs]: Likewise.
>   (volk)[inputs]: Likewise.
>   (freehdl)[inputs]: Likewise.
>   (freecad)[inputs]: Likewise.

Redone or current cu.
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 338510d813..a9829b5be2 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -61,6 +61,7 @@ 
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
@@ -198,7 +199,8 @@ 
                          qt)))
                #t))))))
     (inputs
-     `(("boost" ,boost)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("boost" ,boost)
        ("muparser" ,muparser)
        ("freetype" ,freetype)
        ("qtbase" ,qtbase)
@@ -447,7 +449,8 @@  features.")))
              (setenv "DISPLAY" ":1")
              #t)))))
     (inputs
-     `(("dbus" ,dbus)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("dbus" ,dbus)
        ("mesa" ,mesa)
        ("udev" ,eudev) ;FIXME: required by mesa
        ("glu" ,glu)
@@ -979,7 +982,8 @@  Emacs).")
        ("swig" ,swig)
        ("zlib" ,zlib)))
     (inputs
-     `(("cairo" ,cairo)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("cairo" ,cairo)
        ("curl" ,curl)
        ("glew" ,glew)
        ("glm" ,glm)
@@ -1218,7 +1222,8 @@  the 'showing the effect of'-style of operation.")
                    (,(string-append python "/bin:")))))
              #t)))))
     (inputs
-     `(("boost" ,boost)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("boost" ,boost)
        ("python" ,python-wrapper)
        ("python-mako" ,python-mako)))
     (home-page "https://www.libvolk.org/")
@@ -2017,7 +2022,8 @@  parallel computing platforms.  It also supports serial execution.")
                  `("PKG_CONFIG_PATH" ":" prefix (,(string-append out "/lib/pkgconfig")))))
              #t)))))
     (inputs
-     `(("coreutils" ,coreutils)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("coreutils" ,coreutils)
        ("gcc-toolchain" ,gcc-toolchain)
        ("guile" ,guile-2.2)
        ("perl" ,perl)
@@ -2390,7 +2396,8 @@  comments.")))
        ("python-pyside-2-tools" ,python-pyside-2-tools)
        ("swig" ,swig)))
     (inputs
-     `(("boost" ,boost)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("boost" ,boost)
        ("coin3D" ,coin3D)
        ("double-conversion" ,double-conversion)
        ("eigen" ,eigen)