diff mbox series

[bug#49327,core-updates,075/128] gnu: byobu: Add 'bash' input for 'wrap-program'.

Message ID 20210702100814.23249-75-maximedevos@telenet.be
State New
Headers show
Series Add 'bash' input for 'wrap-program'. | expand

Commit Message

M July 2, 2021, 10:07 a.m. UTC
It is required for cross-compilation.

* gnu/packages/screen.scm (byobu)[inputs]: Add 'bash-minimal'.
---
 gnu/packages/screen.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index af40bd73f9..c3f4910004 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -29,6 +29,7 @@ 
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages hurd)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
@@ -117,7 +118,8 @@  controlling terminal and attach to it later.")
        (patches (search-patches "byobu-writable-status.patch"))))
     (build-system gnu-build-system)
     (inputs
-     `(("python" ,python-wrapper)       ; for config and session GUIs
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("python" ,python-wrapper)       ; for config and session GUIs
        ("python-newt" ,newt "python")))
     (arguments
      `(#:phases