diff mbox series

[bug#49327,core-updates,043/128] gnu: web: Add 'bash' input for 'wrap-program'.

Message ID 20210702100814.23249-43-maximedevos@telenet.be
State New
Headers show
Series Add 'bash' input for 'wrap-program'. | expand

Commit Message

M July 2, 2021, 10:06 a.m. UTC
It is required for cross-compilation.

* gnu/packages/web.scm
  (krona-tools)[inputs]: Add 'bash-minimal'.
  (guix-data-service)[inputs]: Likewise.
  (ikiwiki)[inputs]: Likewise.
  (varnish)[inputs]: Likewise.
  (hiawatha)[inputs]: Likewise.
  (hpcguix-web)[inputs]: Likewise.
  (kiwix-desktop)[inputs]: Likewise.
---
 gnu/packages/web.scm | 22 +++++++++++++++-------
 1 file changed, 15 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 98a3ce5983..b846fca2ed 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -95,6 +95,7 @@ 
   #:use-module (gnu packages apr)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages bittorrent)
   #:use-module (gnu packages boost)
@@ -1284,7 +1285,8 @@  efficiently.  It gives the application developer no more than 4 methods.")
                (invoke (string-append (assoc-ref outputs "out") "/bin/ktImportText")
                        "ec.tsv")))))))
    (inputs
-    `(("curl" ,curl)
+    `(("bash" ,bash-minimal) ; for wrap-program
+      ("curl" ,curl)
       ("make" ,gnu-make)
       ("perl" ,perl)))
    (home-page "https://github.com/marbl/Krona/wiki")
@@ -4841,7 +4843,8 @@  CDF, Atom 0.3, and Atom 1.0 feeds.")
                  #t)))
            (delete 'strip))))           ; As the .go files aren't compatible
       (inputs
-       `(("guix" ,guix)
+       `(("bash" ,bash-minimal) ; for wrap-program
+         ("guix" ,guix)
          ("guile-fibers" ,guile-fibers)
          ("guile-json" ,guile-json-4)
          ("guile-email" ,guile-email)
@@ -5277,7 +5280,8 @@  NetSurf project.")
        ("cvs" ,cvs)
        ("mercurial" ,mercurial)))
     (inputs
-     `(("python" ,python-wrapper)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("python" ,python-wrapper)
        ("perl-authen-passphrase" ,perl-authen-passphrase)
        ("perl-cgi-simple" ,perl-cgi-simple)
        ("perl-db-file" ,perl-db-file)
@@ -6052,7 +6056,8 @@  deployments.")
        ("python-sphinx" ,python-sphinx)
        ("rst2man" ,python-docutils)))
     (inputs
-     `(("jemalloc" ,jemalloc)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("jemalloc" ,jemalloc)
        ("ncurses" ,ncurses)
        ("pcre" ,pcre)
        ("python" ,python-wrapper)
@@ -6230,7 +6235,8 @@  functions of Tidy.")
                  `("PATH" ":" prefix (,mbed)))))))))
     (inputs
      ;; TODO: package "hiawatha-monitor", an optional dependency of "hiawatha".
-     `(("libxslt" ,libxslt)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("libxslt" ,libxslt)
        ("libxml2" ,libxml2)
        ("mbedtls-apache" ,mbedtls-for-hiawatha)
        ("nghttp2" ,nghttp2 "lib")
@@ -7761,7 +7767,8 @@  compressed JSON header blocks.
          ("uglify-js" ,uglify-js)
          ("pkg-config" ,pkg-config)))
       (inputs
-       `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
+       `(("bash" ,bash-minimal) ; for wrap-program
+         ("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
          ("guix" ,guix)))
       (propagated-inputs
        `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
@@ -8136,7 +8143,8 @@  It contains the code shared by all Kiwix ports.")
                  `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
                #t))))))
     (inputs
-     `(("curl" ,curl)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("curl" ,curl)
        ("icu4c" ,icu4c)
        ("kiwix-lib" ,kiwix-lib)
        ("libmicrohttpd" ,libmicrohttpd)