diff mbox series

[bug#49327,core-updates,021/128] gnu: animation: Add 'bash' input for 'wrap-program'.

Message ID 20210702100814.23249-21-maximedevos@telenet.be
State New
Headers show
Series Add 'bash' input for 'wrap-program'. | expand

Commit Message

M July 2, 2021, 10:06 a.m. UTC
It is required for cross-compilation.

* gnu/packages/animation.scm
  (synfigstudio)[inputs]: Add 'bash-minimal'.
  (pagagayo)[inputs]: Likewise.
  (pencil2d)[inputs]: Likewise.
---
 gnu/packages/animation.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

Comments

Maxim Cournoyer Oct. 20, 2023, 4:10 p.m. UTC | #1
Hi,

Maxime Devos <maximedevos@telenet.be> writes:

> It is required for cross-compilation.
>
> * gnu/packages/animation.scm
>   (synfigstudio)[inputs]: Add 'bash-minimal'.
>   (pagagayo)[inputs]: Likewise.
>   (pencil2d)[inputs]: Likewise.

Applied!
diff mbox series

Patch

diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 71fc8f20b0..9e8c42a0e3 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -32,6 +32,7 @@ 
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages assembly)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
@@ -225,7 +226,8 @@  for tweening, preventing the need to hand-draw each frame.")
                  `("XDG_DATA_DIRS" ":" prefix (,gtk-share)))
                #t))))))
     (inputs
-     `(("gtkmm" ,gtkmm)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("gtkmm" ,gtkmm)
        ("gtk+" ,gtk+)
        ("libsigc++" ,libsigc++)
        ("synfig" ,synfig)))
@@ -450,7 +452,8 @@  language.")
                            qt)))
                  #t))))))
       (inputs
-       `(("qt" ,qtbase)
+       `(("bash" ,bash-minimal) ; for wrap-program
+         ("qt" ,qtbase)
          ("qtmultimedia" ,qtmultimedia)
          ("libsndfile" ,libsndfile)))
       (native-inputs
@@ -480,7 +483,8 @@  waveform until they line up with the proper sounds.")
                 "0b1nwiwyg01087q318vymg4si76dw41ykxbn2zwd6dqbxzbpr1dh"))))
     (build-system gnu-build-system)
     (inputs
-     `(("qtbase" ,qtbase)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("qtbase" ,qtbase)
        ("qtxmlpatterns" ,qtxmlpatterns)
        ("qtmultimedia" ,qtmultimedia)
        ("qtsvg" ,qtsvg)))