diff mbox series

[bug#49327,core-updates,065/128] gnu: syndication: Add 'bash' input for 'wrap-program'.

Message ID 20210702100814.23249-65-maximedevos@telenet.be
State New
Headers show
Series Add 'bash' input for 'wrap-program'. | expand

Commit Message

M July 2, 2021, 10:07 a.m. UTC
It is required for cross-compilation.

* gnu/packages/syndication.scm
  (cawbird)[inputs]: Add 'bash-minimal'.
  (giara)[inputs]: Likewise.
  (liferea)[inputs]: Likewise.
  (gfeeds)[inputs]: Likewise.
---
 gnu/packages/syndication.scm | 13 +++++++++----
 1 file changed, 9 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 7ec2435522..ead7a252a5 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -33,6 +33,7 @@ 
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages check)
   #:use-module (gnu packages crates-io)
   #:use-module (gnu packages curl)
@@ -130,7 +131,8 @@ 
        ("xmllint" ,libxml2)
        ("xorg-server" ,xorg-server-for-tests)))
     (inputs
-     `(("glib" ,glib)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("glib" ,glib)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gspell" ,gspell)
        ("gstreamer" ,gstreamer)
@@ -194,7 +196,8 @@  cards.")
        ("pkg-config" ,pkg-config)
        ("xmllint" ,libxml2)))
     (inputs
-     `(("glib" ,glib)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("glib" ,glib)
        ("gtk+" ,gtk+)
        ("gtksourceview" ,gtksourceview)
        ("libhandy" ,libhandy)
@@ -388,7 +391,8 @@  file system, and many more features.")
        ("pkg-config" ,pkg-config)
        ("which" ,which)))
     (inputs
-     `(("glib" ,glib)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("glib" ,glib)
        ("glib-networking" ,glib-networking)
        ("gnome-keyring" ,gnome-keyring)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
@@ -612,7 +616,8 @@  that aims to be quite fast and comfortable to it's user.")
        ("gtk+:bin" ,gtk+ "bin")
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("glib" ,glib)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("glib" ,glib)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gtk+" ,gtk+)
        ("hicolor-icon-theme" ,hicolor-icon-theme)