diff mbox series

[bug#49327,core-updates,093/128] gnu: lightdm-djvu: Add 'bash' input for 'wrap-program'.

Message ID 20210702101324.8227-2-maximedevos@telenet.be
State New
Headers show
Series Add 'bash' input for 'wrap-program'. | expand

Commit Message

M July 2, 2021, 10:12 a.m. UTC
It is required for cross-compilation.

* gnu/packages/dejavu.scm
  (didjvu)[inputs]: Add 'bash-minimal'.
  (ocrodjvu)[inputs]: Likewise.
---
 gnu/packages/djvu.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/djvu.scm b/gnu/packages/djvu.scm
index 6423eb124f..9607a1cdf1 100644
--- a/gnu/packages/djvu.scm
+++ b/gnu/packages/djvu.scm
@@ -29,6 +29,7 @@ 
   #:use-module (guix build-system python)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gawk)
@@ -351,7 +352,8 @@  It is able to:
     (native-inputs
      `(("python2-nose" ,python2-nose)))
     (inputs
-     `(("djvulibre" ,djvulibre)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("djvulibre" ,djvulibre)
        ("minidjvu" ,minidjvu)
        ("python" ,python-2)
        ("python2-gamera" ,python2-gamera)
@@ -420,7 +422,8 @@  and background layers of images, which can then be encoded into a DjVu file.")
        ("python2-nose" ,python2-nose)
        ("python2-pillow" ,python2-pillow)))
     (inputs
-     `(("djvulibre" ,djvulibre)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("djvulibre" ,djvulibre)
        ("ocrad" ,ocrad)
        ("python" ,python-2)
        ("python2-djvulibre" ,python2-djvulibre)