diff mbox series

[bug#49327,core-updates,001/128] gnu: admin: Add bash input for 'wrap-program'.

Message ID 20210702100814.23249-1-maximedevos@telenet.be
State New
Headers show
Series Add 'bash' input for 'wrap-program'. | expand

Commit Message

M July 2, 2021, 10:06 a.m. UTC
It is required for cross-compilation.

* gnu/packages/admin.scm
  (isc-dhcp)[inputs]: Add 'bash-minimal'.
  (clusterssh)[inputs]: Likewise.
  (rename)[inputs]: Likewise.
  (wpa-supplicant-gui)[inputs]: Likewise.
  (nmap)[inputs]: Likewise.
  (dstat)[inputs]: Likewise.
---
 gnu/packages/admin.scm | 17 +++++++++++++----
 1 file changed, 13 insertions(+), 4 deletions(-)

Comments

Maxim Cournoyer Oct. 20, 2023, 3:27 a.m. UTC | #1
Hello,

Redid manually, as I couldn't apply it anymore.
M Oct. 20, 2023, 11:35 a.m. UTC | #2
Op 20-10-2023 om 05:27 schreef Maxim Cournoyer:
> Hello,
> 
> Redid manually, as I couldn't apply it anymore.
> 

k, thanks
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f8afc3d374..d9dfe7ab59 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1278,7 +1278,8 @@  connection alive.")
        `(("perl" ,perl)
          ("file" ,file)))
 
-      (inputs `(("inetutils" ,inetutils)
+      (inputs `(("bash" ,bash-minimal) ; for wrap-program
+                ("inetutils" ,inetutils)
                 ,@(if (hurd-target?) '()
                       `(("net-tools" ,net-tools)
                         ("iproute" ,iproute)))
@@ -1458,7 +1459,8 @@  by bandwidth they use.")
        ("perl-test-trap" ,perl-test-trap)
        ("perltidy" ,perltidy)))
     (inputs
-     `(("perl-exception-class" ,perl-exception-class)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("perl-exception-class" ,perl-exception-class)
        ("perl-sort-naturally" ,perl-sort-naturally)
        ("perl-tk" ,perl-tk)
        ("perl-try-tiny" ,perl-try-tiny)
@@ -1503,6 +1505,8 @@  over ssh connections.")
                         (,(string-append out "/lib/perl5/site_perl")))))
                   (find-files "." ".*")))
                #t))))))
+    (inputs
+     `(("bash" ,bash-minimal))) ; for wrap-program
     (native-inputs
      `(("perl-module-build" ,perl-module-build)
        ("perl-test-pod" ,perl-test-pod)
@@ -1887,6 +1891,9 @@  command.")
     (inputs `(("qtbase" ,qtbase)
               ("qtsvg" ,qtsvg)
               ,@(package-inputs wpa-supplicant)))
+    (inputs
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ,@(package-inputs wpa-supplicant)))
     (native-inputs
      ;; For icons.
      `(("imagemagick" ,imagemagick)
@@ -2872,7 +2879,8 @@  done with the @code{auditctl} utility.")
                   #t))))
     (build-system gnu-build-system)
     (inputs
-     `(("openssl" ,openssl)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("openssl" ,openssl)
        ("libpcap" ,libpcap)
        ("pcre" ,pcre)
        ("lua" ,lua)
@@ -2972,7 +2980,8 @@  results (ndiff), and a packet generation and response analysis tool (nping).")
                  `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH"))))
                #t))))))
     (inputs
-     `(("python" ,python-wrapper)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("python" ,python-wrapper)
        ("python-six" ,python-six)))
     (synopsis "Versatile resource statistics tool")
     (description "Dstat is a versatile replacement for @command{vmstat},