diff mbox series

[bug#49327,core-updates,007/128] gnu: games: Add 'bash' input for 'wrap-program'.

Message ID 20210702100814.23249-7-maximedevos@telenet.be
State New
Headers show
Series Add 'bash' input for 'wrap-program'. | expand

Commit Message

M July 2, 2021, 10:06 a.m. UTC
It is required for cross-compilation.

* gnu/packages/games.scm
  (corsix-th)[inputs]: Add 'bash-minimal'.
  (gamine)[inputs]: Likewise.
  (tuxpaint)[inputs]: Likewise.
  (xonotic)[inputs]: Likewise.
  (frozen-bubble)[inputs]: Likewise.
  (flightgear)[inputs]: Likewise.
  (kajongg)[inputs]: Likewise.
  (neverball)[inputs]: Likewise.
---
 gnu/packages/games.scm | 22 +++++++++++++++-------
 1 file changed, 15 insertions(+), 7 deletions(-)

Comments

Maxim Cournoyer Oct. 20, 2023, 4:55 a.m. UTC | #1
Hi,

Maxime Devos <maximedevos@telenet.be> writes:

> It is required for cross-compilation.
>
> * gnu/packages/games.scm
>   (corsix-th)[inputs]: Add 'bash-minimal'.
>   (gamine)[inputs]: Likewise.
>   (tuxpaint)[inputs]: Likewise.
>   (xonotic)[inputs]: Likewise.
>   (frozen-bubble)[inputs]: Likewise.
>   (flightgear)[inputs]: Likewise.
>   (kajongg)[inputs]: Likewise.
>   (neverball)[inputs]: Likewise.

Redone manually.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 19c1f35808..f40737b449 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -980,7 +980,8 @@  allows users to brew while offline.")
        #:tests? #f)) ; TODO need busted package to run tests
     ;; Omit Lua-Socket dependency to disable automatic updates.
     (inputs
-     `(("ffmpeg" ,ffmpeg)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("ffmpeg" ,ffmpeg)
        ("fluid-3" ,fluid-3)
        ("freetype" ,freetype)
        ("lua" ,lua)
@@ -4233,7 +4234,8 @@  Battle for Wesnoth}.")))
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))
     (inputs
-     `(("gstreamer" ,gstreamer)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("gstreamer" ,gstreamer)
        ("gst-plugins-base" ,gst-plugins-base) ; playbin plugin
        ("gst-plugins-good" ,gst-plugins-good) ; for wav playback
        ("gtk+" ,gtk+)))
@@ -5384,7 +5386,8 @@  safety of the Chromium vessel.")
      `(("gperf" ,gperf)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("cairo" ,cairo)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("cairo" ,cairo)
        ("fribidi" ,fribidi)
        ("gettext" ,gettext-minimal)
        ("libpng" ,libpng)
@@ -7929,6 +7932,7 @@  quotation from a collection of quotes.")
     (inputs
      `(("xonotic-data" ,xonotic-data)
        ("alsa-lib" ,alsa-lib)
+       ("bash" ,bash-minimal) ; for wrap-program
        ("curl" ,curl)
        ("libjpeg" ,libjpeg-turbo)
        ("libmodplug" ,libmodplug)
@@ -8197,7 +8201,8 @@  when packaged in Blorb container files or optionally from individual files.")
          ("perl-module-build" ,perl-module-build)
          ("pkg-config" ,pkg-config)))
       (inputs
-       `(("glib" ,glib)
+       `(("bash" ,bash-minimal) ; for wrap-program
+         ("glib" ,glib)
          ("perl-compress-bzip2" ,perl-compress-bzip2)
          ("perl-file-sharedir" ,perl-file-sharedir)
          ("perl-file-slurp" ,perl-file-slurp)
@@ -9274,7 +9279,8 @@  and also provides the base for the FlightGear Flight Simulator.")
                          "--strip-components=1")))
              #t)))))
     (inputs
-     `(("boost" ,boost-for-mysql)       ; same as simgear
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("boost" ,boost-for-mysql)       ; same as simgear
        ("dbus" ,dbus)
        ("eudev" ,eudev)
        ("freeglut" ,freeglut)
@@ -10475,7 +10481,8 @@  This package is part of the KDE games module.")
        ;("perl" ,perl)
        ("kdoctools" ,kdoctools)))
     (inputs
-     `(("kconfig" ,kconfig)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("kconfig" ,kconfig)
        ("kconfigwidgets" ,kconfigwidgets)
        ("kcoreaddons" ,kcoreaddons)
        ("ki18n" ,ki18n)
@@ -12183,7 +12190,8 @@  kingdom.")
       (native-inputs
        `(("gettext" ,gettext-minimal))) ;for msgfmt
       (inputs
-       `(("libjpeg" ,libjpeg-turbo)
+       `(("bash" ,bash-minimal) ; for wrap-program
+         ("libjpeg" ,libjpeg-turbo)
          ("libpng" ,libpng)
          ("libvorbis" ,libvorbis)
          ("physfs" ,physfs)