diff mbox series

[bug#62284,v2,04/71] gnu: Add go-github-com-tidwall-pretty.

Message ID fa85cc10f3fbaefb3173366b339dd73220a41141.1707685293.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 9:03 p.m. UTC
* gnu/packages/golang.scm (go-github-com-tidwall-pretty): New variable.

Change-Id: I9a9e2b846929f52c1b5e7c744e23ffd3a01738fd
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 15d69814b0..d7472fd422 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3432,6 +3432,28 @@  (define-public go-github-com-tidwall-match
 character.")
     (license license:expat)))
 
+(define-public go-github-com-tidwall-pretty
+  (package
+    (name "go-github-com-tidwall-pretty")
+    (version "1.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tidwall/pretty")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0prj9vpjgrca70rvx40kkl566yf9lw4fsbcmszwamwl364696jsb"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/tidwall/pretty"))
+    (home-page "https://github.com/tidwall/pretty")
+    (synopsis "Efficient JSON beautifier and compactor for Go")
+    (description "This package provides fast methods for formatting JSON for
+human readability, or to compact JSON for smaller payloads.")
+    (license license:expat)))
+
 (define-public go-github-com-tj-docopt
   (package
     (name "go-github-com-tj-docopt")