diff mbox series

[bug#62284,v2,61/71] gnu: Add go-github-com-rs-xid.

Message ID 8d98842af748a1d80fb7d4e790aaf20a850880df.1707685294.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 10:08 p.m. UTC
* gnu/packages/golang.scm (go-github-com-rs-xid): New variable.

Change-Id: Ifebcdefa2b0d21918df0851da255ac24312e3762
---
 gnu/packages/golang.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ec13f64bc0..8ac23e735d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11935,6 +11935,27 @@  (define-public go-maunium-net-go-maulogger
     (description "A logger in Go.")
     (license license:mpl2.0)))
 
+(define-public go-github-com-rs-xid
+  (package
+    (name "go-github-com-rs-xid")
+    (version "1.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/rs/xid")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1j1dcrq9napvdfl6g2vd631iv12myirhlmn6kgw8f1jnrkaqgdaz"))))
+    (build-system go-build-system)
+    (arguments (list #:import-path "github.com/rs/xid"))
+    (home-page "https://github.com/rs/zerolog")
+    (synopsis "Globally unique id generator thought for the web")
+    (description "This package is a globally unique id generator library,
+ready to safely be used directly in your server code.")
+    (license license:expat)))
+
 (define-public go-mau-fi-libsignal
   (package
     (name "go-mau-fi-libsignal")