diff mbox series

[bug#62284,v2,11/71] gnu: Add go-google-golang-org-protobuf-encoding-prototext.

Message ID f89222a27aa538a6a49ae6733747b06028df72ad.1707685293.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 9:04 p.m. UTC
* gnu/packages/golang.scm (go-google-golang-org-protobuf-encoding-prototext): New variable.

Change-Id: I7896eb4f82305b8c423256d685cc8bc6cbb12a13
---
 gnu/packages/golang.scm | 7 +++++++
 1 file changed, 7 insertions(+)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6ba0ebd139..631d0b4887 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7801,6 +7801,13 @@  (define-public go-google-golang-org-protobuf-encoding-protowire
 encoding.  Most users should use package @code{proto} to serialize messages in
 the wire format.")))
 
+(define-public go-google-golang-org-protobuf-encoding-prototext
+  (package
+    (inherit (go-google-golang-org-protobuf-package "encoding-prototext"))
+    (synopsis "Serialize protobuf messages as the text format")
+    (description "This package serializes protobuf messages as the text
+format.")))
+
 (define-public go-github-com-mattn-go-zglob
   (package
     (name "go-github-com-mattn-go-zglob")