diff mbox series

[bug#62284,v2,10/71] gnu: Add go-google-golang-org-protobuf-encoding-protowire.

Message ID 6f08a3346e46e998973f9d47d043bff9c0c82bdd.1707685293.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 9:04 p.m. UTC
* gnu/packages/golang.scm (go-google-golang-org-protobuf-encoding-protowire): New variable.

Change-Id: Ic9cae145fe8e0fbac360f3838dfba9392df5bba6
---
 gnu/packages/golang.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 020f153972..6ba0ebd139 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7793,6 +7793,14 @@  (define-public go-google-golang-org-protobuf-reflect-protoregistry
     (description "This package provides data structures to register and
 lookup protobuf descriptor data types.")))
 
+(define-public go-google-golang-org-protobuf-encoding-protowire
+  (package
+    (inherit (go-google-golang-org-protobuf-package "encoding-protowire"))
+    (synopsis "Parse and format the low-level raw wire encoding")
+    (description "This package parses and formats the low-level raw wire
+encoding.  Most users should use package @code{proto} to serialize messages in
+the wire format.")))
+
 (define-public go-github-com-mattn-go-zglob
   (package
     (name "go-github-com-mattn-go-zglob")