diff mbox series

[bug#62284,v2,33/71] gnu: Add go-maunium-net-go-mauflag.

Message ID 892221c93a37ba3758bba7164cb0a234cea51ea2.1707685293.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 9:06 p.m. UTC
* gnu/packages/golang.scm (go-maunium-net-go-mauflag): New variable.

Change-Id: Ic081435ddbc482559eb37b3745f2dcea5a64778e
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8e6650cc51..1904d7382c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11888,6 +11888,28 @@  (define-public go-github-com-onsi-gomega
      "Gomega is the preferred matcher library for the Ginkgo test framework.")
     (license license:expat)))
 
+(define-public go-maunium-net-go-mauflag
+  (package
+    (name "go-maunium-net-go-mauflag")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tulir/mauflag")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "09jv1819jwq5i29y6ngf4j4ii6qwlshydvprfvsfplc419dkz1vx"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "maunium.net/go/mauflag"))
+    (home-page "https://github.com/tulir/mauflag")
+    (synopsis "An extendable argument parser for Golang")
+    (description "An extendable argument parser for Golang.  Mostly follows
+the GNU Program Argument Syntax conventions.")
+    (license license:gpl3)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar