diff mbox series

[bug#62284,v2,07/71] gnu: Add go-google-golang-org-protobuf-proto.

Message ID 986786d1bac36e2878aa2715aa5da269bfede84a.1707685293.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 9:03 p.m. UTC
* gnu/packages/golang.scm (go-google-golang-org-protobuf-proto): New variable.

Change-Id: I39b3b53183faf3ffcb171ed65ff46906c614f6af
---
 gnu/packages/golang.scm | 7 +++++++
 1 file changed, 7 insertions(+)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 933aed82e3..df5f0abe97 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7772,6 +7772,13 @@  (define (go-google-golang-org-protobuf-package suffix)
         (string-append path "/"
                        (string-replace-substring suffix "-" "/")))))))
 
+(define-public go-google-golang-org-protobuf-proto
+  (package (inherit (go-google-golang-org-protobuf-package "proto"))
+    (synopsis "Functions operating on protobuf messages")
+    (description "This package provides functions operating on protobuf
+messages such as cloning, merging, and checking equality, as well as binary
+serialization.")))
+
 (define-public go-github-com-mattn-go-zglob
   (package
     (name "go-github-com-mattn-go-zglob")