diff mbox series

[bug#62284,v2,08/71] gnu: Add go-google-golang-org-protobuf-reflect-protoreflect.

Message ID 6783e7858e50343fe5c7476eb8afc9fc03759770.1707685293.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 9:03 p.m. UTC
* gnu/packages/golang.scm (go-google-golang-org-protobuf-reflect-protoreflect): New variable.

Change-Id: I3285ff77c9a2cadc2ece0929a6c2cbab886ed1a6
---
 gnu/packages/golang.scm | 7 +++++++
 1 file changed, 7 insertions(+)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index df5f0abe97..d2af3cdc04 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7779,6 +7779,13 @@  (define-public go-google-golang-org-protobuf-proto
 messages such as cloning, merging, and checking equality, as well as binary
 serialization.")))
 
+(define-public go-google-golang-org-protobuf-reflect-protoreflect
+  (package
+    (inherit (go-google-golang-org-protobuf-package "reflect-protoreflect"))
+    (synopsis "Dynamically manipulate protobuf messages")
+    (description "This package provides interfaces to dynamically
+manipulate protobuf messages.")))
+
 (define-public go-github-com-mattn-go-zglob
   (package
     (name "go-github-com-mattn-go-zglob")