diff mbox series

[bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson.

Message ID cdbbb5c1e827f42eb64d70eb2df725bf725780e2.1707685293.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 9:02 p.m. UTC
* gnu/packages/golang.scm (go-github-com-tidwall-sjson): New variable.

Change-Id: I6e47207ea6eec02453621105a7019ddd49eefe47
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 6f78803b01d416ab421ba860751b764b9e4f33db
-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 014ca01602..6204f55a8f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3358,6 +3358,31 @@  (define-public go-github-com-tdewolff-hasher
 @code{string} to @code{uint32} mapper.")
     (license license:bsd-3)))
 
+(define-public go-github-com-tidwall-sjson
+  (package
+    (name "go-github-com-tidwall-sjson")
+    (version "1.2.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tidwall/sjson")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "16yaikpxiwqz00zxa70w17k2k52nr06svand88sv2br6b6i8v09r"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/tidwall/sjson"))
+    (propagated-inputs
+     (list go-github-com-tidwall-gjson
+           go-github-com-tidwall-pretty))
+    (home-page "https://github.com/tidwall/sjson")
+    (synopsis "Set JSON values very quickly in Go")
+    (description "This package provides a very fast and simple way to set a
+value in a JSON document.")
+    (license license:expat)))
+
 (define-public go-github-com-tj-docopt
   (package
     (name "go-github-com-tj-docopt")