diff mbox series

[bug#62284,v2,02/71] gnu: Add go-github-com-tidwall-gjson.

Message ID 969d6aed860a7e1fd42183bdd57a74b448f6cb27.1707685293.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 9:02 p.m. UTC
* gnu/packages/golang.scm (go-github-com-tidwall-gjson): New variable.

Change-Id: I509d8e6f7ccdb77c43a2168fbdba4437d6538b53
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6204f55a8f..83a7404154 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3383,6 +3383,32 @@  (define-public go-github-com-tidwall-sjson
 value in a JSON document.")
     (license license:expat)))
 
+(define-public go-github-com-tidwall-gjson
+  (package
+    (name "go-github-com-tidwall-gjson")
+    (version "1.14.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tidwall/gjson")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1rs8i87j62sgas55cvm8kzcgf40090dq38r6m6s03rzxs9hbcd6w"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/tidwall/gjson"))
+    (propagated-inputs
+     (list go-github-com-tidwall-match
+           go-github-com-tidwall-pretty))
+    (home-page "https://github.com/tidwall/gjson")
+    (synopsis "JSON parser for Go")
+    (description "GJSON is a Go package that provides a fast and simple way to
+get values from a JSON document. It has features like one line retrieval, dot
+notation paths, iteration, and parsing JSON lines.")
+    (license license:expat)))
+
 (define-public go-github-com-tj-docopt
   (package
     (name "go-github-com-tj-docopt")