diff mbox series

[bug#62284,v2,03/71] gnu: Add go-github-com-tidwall-match.

Message ID 5afa66017eb6a0334afe1f0a631b231f04071159.1707685293.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 9:03 p.m. UTC
* gnu/packages/golang.scm (go-github-com-tidwall-match): New variable.

Change-Id: I5fd7b9d74944979e345a004793b3a9f0e971c768
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 83a7404154..15d69814b0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3409,6 +3409,29 @@  (define-public go-github-com-tidwall-gjson
 notation paths, iteration, and parsing JSON lines.")
     (license license:expat)))
 
+(define-public go-github-com-tidwall-match
+  (package
+    (name "go-github-com-tidwall-match")
+    (version "1.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tidwall/match")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1n25md63xr5m66r6zc77n6fgcpv2ljrlk92ivp9hvp8xya22as9k"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/tidwall/match"))
+    (home-page "https://github.com/tidwall/match")
+    (synopsis "Simple string pattern matcher for Go")
+    (description "This package is a very simple pattern matcher where @code{*}
+matches on any number of characters and @code{?} matches on any one
+character.")
+    (license license:expat)))
+
 (define-public go-github-com-tj-docopt
   (package
     (name "go-github-com-tj-docopt")