diff mbox series

[bug#62284,v2,63/71] gnu: Add go-github-com-coreos-go-systemd.

Message ID a624942f97d6c7b877e24fe27eba83c1d921ebae.1707685294.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62284,v2,01/71] gnu: Add go-github-com-tidwall-sjson. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 10:08 p.m. UTC
* gnu/packages/golang.scm (go-github-com-coreos-go-systemd): New variable.

Change-Id: I3ba5034303f8e633e19a8996268b24c5074f31c4
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 965460a873..35a4046f63 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11956,6 +11956,28 @@  (define-public go-github-com-rs-xid
 ready to safely be used directly in your server code.")
     (license license:expat)))
 
+(define-public go-github-com-coreos-go-systemd
+  (package
+    (name "go-github-com-coreos-go-systemd")
+    (version "22.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/coreos/go-systemd")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1vhb4cw8nw9nx8mprx829xv8w4jnwhc2lcyjljzlfafsn8nx5nyf"))))
+    (build-system go-build-system)
+    (arguments (list #:import-path "github.com/coreos/go-systemd"))
+    (propagated-inputs (list go-github-com-godbus-dbus))
+    (home-page "https://github.com/coreos/go-systemd")
+    (synopsis "Go bindings to systemd")
+    (description "Go bindings to systemd socket activation, journal, D-Bus,
+and unit files.")
+    (license license:asl2.0)))
+
 (define-public go-mau-fi-libsignal
   (package
     (name "go-mau-fi-libsignal")