diff mbox series

[bug#66801,va3e5ae0f..37252e07,04/32] gnu: erlang-getopt: moved to erlang-xyz.scm

Message ID f8c4db6aa007ea895d87914f0bd13cfb0eff313b.1698590244.git.phfrohring@deeplinks.com
State New
Headers show
Series [bug#66801,va3e5ae0f..37252e07,01/32] rebar-build-system and packages. | expand

Commit Message

Pierre-Henry Fröhring Oct. 29, 2023, 2:36 p.m. UTC
Change-Id: Ic7740512545c8798a4a7927b7aeee6e33f6990a2
---
 gnu/packages/erlang-xyz.scm | 17 +++++++++++++++++
 gnu/packages/erlang.scm     | 17 -----------------
 2 files changed, 17 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 444fa648..6ca0b4ae 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -55,6 +55,23 @@  (define-public erlang-certifi
 Mozilla's canonical set.")
     (license license:bsd-3)))
 
+(define-public erlang-getopt
+  (package
+    (name "erlang-getopt")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "09pasi7ki1rivw9sl7xndj5qgjbdqvcscxk83yk85yr28gm9l0m0"))))
+    (build-system rebar-build-system)
+    (home-page "https://github.com/jcomellas/getopt")
+    (synopsis "Command-line options parser for Erlang")
+    (description "This package provides an Erlang module to parse command line
+arguments using the GNU getopt syntax.")
+    (license license:bsd-3)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index c729ab8a..6c3b845b 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -405,23 +405,6 @@  (define-public erlang-eunit-formatters
     (description "This package provides a better output for Erlang eunits.")
     (license license:asl2.0)))
 
-(define-public erlang-getopt
-  (package
-    (name "erlang-getopt")
-    (version "1.0.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (hexpm-uri name version))
-       (sha256
-        (base32 "09pasi7ki1rivw9sl7xndj5qgjbdqvcscxk83yk85yr28gm9l0m0"))))
-    (build-system rebar-build-system)
-    (home-page "https://github.com/jcomellas/getopt")
-    (synopsis "Command-line options parser for Erlang")
-    (description "This package provides an Erlang module to parse command line
-arguments using the GNU getopt syntax.")
-    (license license:bsd-3)))
-
 (define-public erlang-hex-core
   (package
     (name "erlang-hex-core")