diff mbox series

[bug#66801,va3e5ae0f..37252e07,32/32] gnu: erlang-telemetry: moved to erlang-xyz.scm

Message ID 37252e07b4bdf9451b58dcd92f0eab37c3c73fa4.1698590244.git.phfrohring@deeplinks.com
State New
Headers show
Series [bug#66801,va3e5ae0f..37252e07,01/32] rebar-build-system and packages. | expand

Commit Message

Pierre-Henry Fröhring Oct. 29, 2023, 2:37 p.m. UTC
Change-Id: I54cfe6fb244c26c6a226d76ee62a502a72e198a7
---
 gnu/packages/erlang-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 366c5f2c..b43b4403 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -648,6 +648,27 @@  (define-public erlang-covertool
 was previously called @code{rebar_covertool}.")
     (license license:bsd-2)))
 
+(define-public erlang-telemetry
+  (package
+    (name "erlang-telemetry")
+    (version "1.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "1mgyx9zw92g6w8fp9pblm3b0bghwxwwcbslrixq23ipzisfwxnfs"))))
+    (build-system rebar-build-system)
+    (native-inputs (list erlang-covertool))
+    (synopsis "Dynamic dispatching library for metrics and instrumentations")
+    (description
+     "Telemetry is a lightweight library for dynamic dispatching of events, with a
+focus on metrics and instrumentation. Any Erlang or Elixir library can use
+telemetry to emit events. Application code and other libraries can then hook
+into those events and run custom handlers.")
+    (home-page "https://hexdocs.pm/telemetry/")
+    (license license:asl2.0)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar