diff mbox series

[bug#66801,va3e5ae0f..37252e07,30/32] gnu: erlang-geas: moved to erlang-xyz.scm

Message ID f303240b4a699865db631ad4984a3dd52aa78459.1698590244.git.phfrohring@deeplinks.com
State New
Headers show
Series [bug#66801,va3e5ae0f..37252e07,01/32] rebar-build-system and packages. | expand

Commit Message

Pierre-Henry Fröhring Oct. 29, 2023, 2:37 p.m. UTC
Change-Id: If9d92d8da4b50d0832fb51a8e331b5a30394e81f
---
 gnu/packages/erlang-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index bd4f78fe..6642aeea 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -605,6 +605,28 @@  (define-public erlang-samovar
     (home-page "https://hexdocs.pm/samovar/")
     (license license:isc)))
 
+(define-public erlang-geas
+  (package
+    (name "erlang-geas")
+    (version "2.7.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "1maxv5zg2ckrikr8xpxgg9kpfaxvahqilbkl9dl9ibchlgrbj6i4"))))
+    (build-system rebar-build-system)
+    (propagated-inputs (list erlang-samovar))
+    (synopsis
+     "Tool to detect the runnable official Erlang release window for your project")
+    (description
+     "Geas will tell you also what are the offending functions in the beam/source
+files that reduce the available window, if some beam files are compiled native
+and the installed patches and recommend patches that should be installed
+depending your code.")
+    (home-page "https://hexdocs.pm/geas/")
+    (license license:isc)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar