diff mbox series

[bug#66801,va3e5ae0f..37252e07,06/32] gnu: erlang-rebar3-git-vsn: moved to erlang-xyz.scm

Message ID 44bec23d6d48ecc169f1bec65a465edd7c32e973.1698590244.git.phfrohring@deeplinks.com
State New
Headers show
Series [bug#66801,va3e5ae0f..37252e07,01/32] rebar-build-system and packages. | expand

Commit Message

Pierre-Henry Fröhring Oct. 29, 2023, 2:36 p.m. UTC
Change-Id: I5a743e71b2034ba1cfe71fe6121137b3194befed
---
 gnu/packages/erlang-xyz.scm | 32 +++++++++++++++++++++++++++++++-
 gnu/packages/erlang.scm     | 31 -------------------------------
 2 files changed, 31 insertions(+), 32 deletions(-)

Comments

Liliana Marie Prikler Oct. 29, 2023, 7:31 p.m. UTC | #1
Am Sonntag, dem 29.10.2023 um 15:36 +0100 schrieb Pierre-Henry
Fröhring:
> Change-Id: I5a743e71b2034ba1cfe71fe6121137b3194befed
> ---
Depending on how many packages you want to add, you might want to do an
even stronger split, e.g. erlang-build for rebar and mix, erlang-check,
erlang-WHATEVER, and then erlang-xyz for what doesn't fit into any of
the other categories.

Also missing ChangeLog as with the rest.

I don't see mix in the mix yet.  Is this going to be a two series
thing?

Cheers
Pierre-Henry Fröhring Oct. 29, 2023, 7:42 p.m. UTC | #2
Thank you for being so responsive ; it's pleasantly surprising.
I will address the mix-build-system in 15 additional commits,
which I will send after incorporating your feedback to prevent any further
errors.
I plan to tackle this tomorrow.

Cheers.
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 5815d19f..bfc4802a 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -25,7 +25,6 @@  (define-module (gnu packages erlang-xyz)
   #:use-module (guix download)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
-  #:use-module (guix git-download)
   #:use-module (guix hg-download)
   #:use-module (guix packages)
   #:use-module (guix utils)
@@ -89,6 +88,37 @@  (define-public erlang-edown
 Markdown.")
     (license license:asl2.0)))
 
+(define-public erlang-rebar3-git-vsn
+  (package
+    (name "erlang-rebar3-git-vsn")
+    (version "1.1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (hexpm-uri name version))
+        (sha256
+          (base32 "1dfz56034pa25axly9vqdzv3phkn8ll0qwrkws96pbgcprhky1hx"))))
+    (build-system rebar-build-system)
+    (inputs
+     (list git-minimal/pinned))
+    (arguments
+     `(;; Running the tests require binary artifact (tar-file containing
+       ;; samples git repos)  TODO: remove these from the source
+       #:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((git (assoc-ref inputs "git-minimal")))
+               (substitute* "src/rebar3_git_vsn.erl"
+                 (("rebar_utils:sh\\(\"git " _)
+                  (string-append "rebar_utils:sh(\"" git "/bin/git ")))))))))
+    (home-page "https://github.com/soranoba/rebar3_git_vsn")
+    (synopsis "Rebar3 plugin for generating the version from git")
+    (description "This plugin adds support for generating the version from
+a git checkout.")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 5148abf0..6320e3d0 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -655,37 +655,6 @@  (define-public erlang-rebar3-raw-deps
 applications as a dependent libraries.")
     (license license:expat)))
 
-(define-public erlang-rebar3-git-vsn
-  (package
-    (name "erlang-rebar3-git-vsn")
-    (version "1.1.1")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (hexpm-uri name version))
-        (sha256
-          (base32 "1dfz56034pa25axly9vqdzv3phkn8ll0qwrkws96pbgcprhky1hx"))))
-    (build-system rebar-build-system)
-    (inputs
-     (list git-minimal/pinned))
-    (arguments
-     `(;; Running the tests require binary artifact (tar-file containing
-       ;; samples git repos)  TODO: remove these from the source
-       #:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-path
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((git (assoc-ref inputs "git-minimal")))
-               (substitute* "src/rebar3_git_vsn.erl"
-                 (("rebar_utils:sh\\(\"git " _)
-                  (string-append "rebar_utils:sh(\"" git "/bin/git ")))))))))
-    (home-page "https://github.com/soranoba/rebar3_git_vsn")
-    (synopsis "Rebar3 plugin for generating the version from git")
-    (description "This plugin adds support for generating the version from
-a git checkout.")
-    (license license:expat)))
-
 (define-public erlang-rebar3-proper
   (package
     (name "erlang-rebar3-proper")