diff mbox series

[bug#66801,va3e5ae0f..37252e07,24/32] gnu: erlang-idna: moved to erlang-xyz.scm

Message ID ec0ba8e8b45e180f19e21917403869f11ffe8f88.1698590244.git.phfrohring@deeplinks.com
State New
Headers show
Series [bug#66801,va3e5ae0f..37252e07,01/32] rebar-build-system and packages. | expand

Commit Message

Pierre-Henry Fröhring Oct. 29, 2023, 2:37 p.m. UTC
Change-Id: Ifb67d5364658ee59bb8286c3f454ce4f95d0db2b
---
 gnu/packages/erlang-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index f0c8521c..67be758c 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -499,6 +499,27 @@  (define-public erlang-unicode-util-compat
     (home-page "https://hex.pm/packages/unicode_util_compat")
     (license license:asl2.0)))
 
+(define-public erlang-idna
+  (package
+    (name "erlang-idna")
+    (version "6.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "1sjcjibl34sprpf1dgdmzfww24xlyy34lpj7mhcys4j4i6vnwdwj"))))
+    (build-system rebar-build-system)
+    (propagated-inputs (list erlang-unicode-util-compat))
+    (synopsis
+     "Erlang Internationalized Domain Names in Applications (IDNA) protocol")
+    (description
+     "Library to register and look up IDNs in a way
+   that does not require changes to the DNS itself.  IDNA is only meant for
+processing domain names, not free text. See: RFC 5891.")
+    (home-page "https://hexdocs.pm/idna/")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar