diff mbox series

[bug#66801,va3e5ae0f..37252e07,09/32] gnu: erlang-bbmustache: moved to erlang-xyz.scm

Message ID 6d932942fee25dd60756618f5685d5960f88aa0e.1698590244.git.phfrohring@deeplinks.com
State New
Headers show
Series [bug#66801,va3e5ae0f..37252e07,01/32] rebar-build-system and packages. | expand

Commit Message

Pierre-Henry Fröhring Oct. 29, 2023, 2:37 p.m. UTC
Change-Id: Ied29a387cbaef59f16613d7425417da4fc8eed0c
---
 gnu/packages/erlang-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 gnu/packages/erlang.scm     | 32 --------------------------------
 2 files changed, 32 insertions(+), 32 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 426a5f95..5a966d2a 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -153,6 +153,38 @@  (define-public erlang-rebar3-proper
 rebar3.")
     (license license:bsd-3)))
 
+(define-public erlang-bbmustache
+  (package
+    (name "erlang-bbmustache")
+    (version "1.12.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "0fvvaxdpziygxl30j59g98qkh2n47xlb7w5dfpsm2bfcsnj372v8"))))
+    (build-system rebar-build-system)
+    (inputs
+     (list erlang-getopt erlang-rebar3-git-vsn
+           erlang-edown))  ; for building the docs
+    (arguments
+     `(#:tests? #f ;; requires mustache specification file
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'build-more
+           (lambda _
+             (invoke "rebar3" "as" "dev" "escriptize")))
+         (add-after 'install 'install-escript
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out")))
+               (install-file "_build/dev/bin/bbmustache"
+                             (string-append out "/bin"))))))))
+    (home-page "https://github.com/soranoba/bbmustache/")
+    (synopsis "Binary pattern match Based Mustache template engine for Erlang")
+    (description "This Erlang library provides a Binary pattern match Based
+Mustache template engine")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 8269cba1..c0cbf5a6 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -232,38 +232,6 @@  (define-public emacs-erlang
 files.")
     (license license:asl2.0)))
 
-(define-public erlang-bbmustache
-  (package
-    (name "erlang-bbmustache")
-    (version "1.12.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (hexpm-uri name version))
-       (sha256
-        (base32 "0fvvaxdpziygxl30j59g98qkh2n47xlb7w5dfpsm2bfcsnj372v8"))))
-    (build-system rebar-build-system)
-    (inputs
-     (list erlang-getopt erlang-rebar3-git-vsn
-           erlang-edown))  ; for building the docs
-    (arguments
-     `(#:tests? #f ;; requires mustache specification file
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'build-more
-           (lambda _
-             (invoke "rebar3" "as" "dev" "escriptize")))
-         (add-after 'install 'install-escript
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out")))
-               (install-file "_build/dev/bin/bbmustache"
-                             (string-append out "/bin"))))))))
-    (home-page "https://github.com/soranoba/bbmustache/")
-    (synopsis "Binary pattern match Based Mustache template engine for Erlang")
-    (description "This Erlang library provides a Binary pattern match Based
-Mustache template engine")
-    (license license:expat)))
-
 (define-public erlang-cf
   (package
     (name "erlang-cf")