diff mbox series

[bug#66801,va3e5ae0f..37252e07,19/32] gnu: erlang-relx: moved to erlang-xyz.scm

Message ID ca09ccea336fa4a03074e7e417f7916d29bb6e3d.1698590244.git.phfrohring@deeplinks.com
State New
Headers show
Series [bug#66801,va3e5ae0f..37252e07,01/32] rebar-build-system and packages. | expand

Commit Message

Pierre-Henry Fröhring Oct. 29, 2023, 2:37 p.m. UTC
Change-Id: Ibeaa35080cf5ef271ce79faa4f1eddc5451acb14
---
 gnu/packages/erlang-xyz.scm | 22 ++++++++++++++++++++++
 gnu/packages/erlang.scm     | 22 ----------------------
 2 files changed, 22 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 1d7984fb..ad56b9d2 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -379,6 +379,28 @@  (define-public erlang-jsx
     (home-page "https://github.com/talentdeficit/jsx")
     (license license:expat)))
 
+(define-public erlang-relx
+  (package
+    (name "erlang-relx")
+    (version "4.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "02gmfx1vxg9m3mq4njsqhs4972l4nb8m5p1pdcf64g09ccf17y1g"))))
+    (build-system rebar-build-system)
+    (propagated-inputs
+     (list erlang-bbmustache))
+    (home-page "https://erlware.github.io/relx/")
+    (synopsis "Release assembler for Erlang/OTP Releases")
+    (description "Relx assembles releases for an Erlang/OTP release.  Given a
+release specification and a list of directories in which to search for OTP
+applications it will generate a release output.  That output depends heavily on
+what plugins available and what options are defined, but usually it is simply
+a well configured release directory.")
+    (license license:asl2.0)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index eeaf7cf0..c4e81aa2 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -297,28 +297,6 @@  (define-public erlang-providers
     (description "This package provides an Erlang providers library.")
     (license license:asl2.0)))
 
-(define-public erlang-relx
-  (package
-    (name "erlang-relx")
-    (version "4.6.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (hexpm-uri name version))
-       (sha256
-        (base32 "02gmfx1vxg9m3mq4njsqhs4972l4nb8m5p1pdcf64g09ccf17y1g"))))
-    (build-system rebar-build-system)
-    (propagated-inputs
-     (list erlang-bbmustache))
-    (home-page "https://erlware.github.io/relx/")
-    (synopsis "Release assembler for Erlang/OTP Releases")
-    (description "Relx assembles releases for an Erlang/OTP release.  Given a
-release specification and a list of directories in which to search for OTP
-applications it will generate a release output.  That output depends heavily on
-what plugins available and what options are defined, but usually it is simply
-a well configured release directory.")
-    (license license:asl2.0)))
-
 (define-public erlang-ssl-verify-fun
   (package
     (name "erlang-ssl-verify-fun")