diff mbox series

[bug#66801,va3e5ae0f..37252e07,12/32] gnu: erlang-covertool: moved to erlang-xyz.scm

Message ID c331299dde496ae8dcaa5033d5e0750620868488.1698590244.git.phfrohring@deeplinks.com
State New
Headers show
Series [bug#66801,va3e5ae0f..37252e07,01/32] rebar-build-system and packages. | expand

Commit Message

Pierre-Henry Fröhring Oct. 29, 2023, 2:37 p.m. UTC
Change-Id: I1212ff469a12e926d4728106c15f12b181819e2c
---
 gnu/packages/erlang-xyz.scm | 21 +++++++++++++++++++++
 gnu/packages/erlang.scm     | 21 ---------------------
 2 files changed, 21 insertions(+), 21 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 78f829e9..ae2193f5 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -224,6 +224,27 @@  (define-public erlang-yamerl
     (home-page "https://hexdocs.pm/yamerl/")
     (license license:bsd-2)))
 
+(define-public erlang-covertool
+  (package
+    (name "erlang-covertool")
+    (version "2.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "1p0c1n3nl4063xwi1sv176l1x68xqf07qwvj444a5z888fx6i5aw"))))
+    (build-system rebar-build-system)
+    (home-page "https://github.com/covertool/covertool")
+    (synopsis "Convert code-coverage data generated by @code{cover} into
+Cobertura XML reports")
+    (description "This package provides a build tool and plugin to convert
+exported Erlang @code{cover} data sets into Cobertura XML reports, which can
+then be feed to the Jenkins Cobertura plug-in.
+
+On @emph{hex.pm}, this plugin was previously called @code{rebar_covertool}.")
+    (license license:bsd-2)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 5ed11c28..55a6edb7 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -232,27 +232,6 @@  (define-public emacs-erlang
 files.")
     (license license:asl2.0)))
 
-(define-public erlang-covertool
-  (package
-    (name "erlang-covertool")
-    (version "2.0.4")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (hexpm-uri name version))
-       (sha256
-        (base32 "1p0c1n3nl4063xwi1sv176l1x68xqf07qwvj444a5z888fx6i5aw"))))
-    (build-system rebar-build-system)
-    (home-page "https://github.com/covertool/covertool")
-    (synopsis "Convert code-coverage data generated by @code{cover} into
-Cobertura XML reports")
-    (description "This package provides a build tool and plugin to convert
-exported Erlang @code{cover} data sets into Cobertura XML reports, which can
-then be feed to the Jenkins Cobertura plug-in.
-
-On @emph{hex.pm}, this plugin was previously called @code{rebar_covertool}.")
-    (license license:bsd-2)))
-
 (define-public erlang-cth-readable
   (package
     (name "erlang-cth-readable")