diff mbox series

[bug#66801,va3e5ae0f..37252e07,03/32] gnu: erlang-certifi: moved to erlang-xyz.scm

Message ID 7c58f0885d71a76a852380230a2563eaf9508002.1698590244.git.phfrohring@deeplinks.com
State New
Headers show
Series [bug#66801,va3e5ae0f..37252e07,01/32] rebar-build-system and packages. | expand

Commit Message

Pierre-Henry Fröhring Oct. 29, 2023, 2:36 p.m. UTC
Change-Id: I7491af542af5ffb2d82b5555675f4f7dbef167af
---
 gnu/packages/erlang-xyz.scm | 62 +++++++++++++++++++++++++++++++++++++
 gnu/packages/erlang.scm     | 25 +--------------
 2 files changed, 63 insertions(+), 24 deletions(-)
 create mode 100644 gnu/packages/erlang-xyz.scm

Comments

Liliana Marie Prikler Oct. 29, 2023, 7:25 p.m. UTC | #1
Am Sonntag, dem 29.10.2023 um 15:36 +0100 schrieb Pierre-Henry
Fröhring:
> Change-Id: I7491af542af5ffb2d82b5555675f4f7dbef167af
Missing ChangeLog.
> ---
>  gnu/packages/erlang-xyz.scm | 62
> +++++++++++++++++++++++++++++++++++++
>  gnu/packages/erlang.scm     | 25 +--------------
>  2 files changed, 63 insertions(+), 24 deletions(-)
>  create mode 100644 gnu/packages/erlang-xyz.scm
> 
> diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-
> xyz.scm
> new file mode 100644
> index 00000000..444fa648
> --- /dev/null
> +++ b/gnu/packages/erlang-xyz.scm
> @@ -0,0 +1,62 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2023 Pierre-Henry Fröhring
> <phfrohring@deeplinks.com>
> +;;;
Don't forget to carry over all other relevant copyright headers. 
Likewise for the following patches.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
new file mode 100644
index 00000000..444fa648
--- /dev/null
+++ b/gnu/packages/erlang-xyz.scm
@@ -0,0 +1,62 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Pierre-Henry Fröhring <phfrohring@deeplinks.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages erlang-xyz)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages version-control)
+  #:use-module (gnu packages)
+  #:use-module (guix build-system rebar)
+  #:use-module (guix download)
+  #:use-module (guix gexp)
+  #:use-module (guix git-download)
+  #:use-module (guix git-download)
+  #:use-module (guix hg-download)
+  #:use-module (guix packages)
+  #:use-module (guix utils)
+  #:use-module (srfi srfi-1)
+  #:use-module (srfi srfi-26))
+
+(define-public erlang-certifi
+  (package
+    (name "erlang-certifi")
+    (version "2.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "0ha6vmf5p3xlbf5w1msa89frhvfk535rnyfybz9wdmh6vdms8v96"))))
+    (build-system rebar-build-system)
+    (arguments `(#:tests? #f)) ;; have not been updated for latest cert bundle
+    (home-page "https://github.com/certifi/erlang-certifi/")
+    (synopsis "Erlang CA certificate bundle")
+    (description "This Erlang library contains a CA bundle that you can
+reference in your Erlang application.  This is useful for systems that do not
+have CA bundles that Erlang can find itself, or where a uniform set of CAs is
+valuable.
+
+This an Erlang specific port of certifi.  The CA bundle is derived from
+Mozilla's canonical set.")
+    (license license:bsd-3)))
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above by existing packages with similar
+;;; functionality or similar names.
+;;;
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index dafc0e81..c729ab8a 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -29,6 +29,7 @@ 
 (define-module (gnu packages erlang)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages elixir)
+  #:use-module (gnu packages erlang-xyz)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages ncurses)
@@ -263,30 +264,6 @@  (define-public erlang-bbmustache
 Mustache template engine")
     (license license:expat)))
 
-(define-public erlang-certifi
-  (package
-    (name "erlang-certifi")
-    (version "2.9.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (hexpm-uri name version))
-       (sha256
-        (base32 "0ha6vmf5p3xlbf5w1msa89frhvfk535rnyfybz9wdmh6vdms8v96"))))
-    (build-system rebar-build-system)
-    (arguments
-     `(#:tests? #f)) ;; have not been updated for latest cert bundle
-    (home-page "https://github.com/certifi/erlang-certifi/")
-    (synopsis "Erlang CA certificate bundle")
-    (description "This Erlang library contains a CA bundle that you can
-reference in your Erlang application.  This is useful for systems that do not
-have CA bundles that Erlang can find itself, or where a uniform set of CAs is
-valuable.
-
-This an Erlang specific port of certifi.  The CA bundle is derived from
-Mozilla's canonical set.")
-    (license license:bsd-3)))
-
 (define-public erlang-cf
   (package
     (name "erlang-cf")