diff mbox series

[bug#66801,va3e5ae0f..37252e07,17/32] gnu: erlang-hex-core: moved to erlang-xyz.scm

Message ID 14a87086ed3815e099c5bc2f641718f31b136939.1698590244.git.phfrohring@deeplinks.com
State New
Headers show
Series [bug#66801,va3e5ae0f..37252e07,01/32] rebar-build-system and packages. | expand

Commit Message

Pierre-Henry Fröhring Oct. 29, 2023, 2:37 p.m. UTC
Change-Id: Id69281bb2ec1847723582a461b0fa87df1c3ace7
---
 gnu/packages/erlang-xyz.scm | 26 ++++++++++++++++++++++++++
 gnu/packages/erlang.scm     | 26 --------------------------
 2 files changed, 26 insertions(+), 26 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index b83bc6c0..2ce2e3f0 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -336,6 +336,32 @@  (define-public erlang-eunit-formatters
     (description "This package provides a better output for Erlang eunits.")
     (license license:asl2.0)))
 
+(define-public erlang-hex-core
+  (package
+    (name "erlang-hex-core")
+    (version "0.8.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "06p65hlm29ky03vs3fq3qz6px2ylwp8b0f2y75wdf5cm0kx2332b"))))
+    (build-system rebar-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "rebar3" "as" "test" "proper")))))))
+    (inputs
+     (list erlang-proper erlang-rebar3-proper))
+    (home-page "https://github.com/hexpm/hex_core")
+    (synopsis "Reference implementation of Hex specifications")
+    (description "This package provides the reference implementation of Hex
+specifications.")
+    (license license:asl2.0)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 8d3b682c..c509282d 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -232,32 +232,6 @@  (define-public emacs-erlang
 files.")
     (license license:asl2.0)))
 
-(define-public erlang-hex-core
-  (package
-    (name "erlang-hex-core")
-    (version "0.8.4")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (hexpm-uri name version))
-       (sha256
-        (base32 "06p65hlm29ky03vs3fq3qz6px2ylwp8b0f2y75wdf5cm0kx2332b"))))
-    (build-system rebar-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "rebar3" "as" "test" "proper")))))))
-    (inputs
-     (list erlang-proper erlang-rebar3-proper))
-    (home-page "https://github.com/hexpm/hex_core")
-    (synopsis "Reference implementation of Hex specifications")
-    (description "This package provides the reference implementation of Hex
-specifications.")
-    (license license:asl2.0)))
-
 (define-public erlang-jsone
   (package
     (name "erlang-jsone")