diff mbox series

[bug#70146,075/147] gnu: Add rust-wasmtime-component-util-18.

Message ID efc84ef035b82e9c3d0453c4aae5ecb22b8e5b25.1712070307.git.jean@foundation.xyz
State New
Headers show
Series [bug#70146,001/147] gnu: rust-anyhow-1: Update to 1.0.80. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 2, 2024, 4:04 p.m. UTC
* gnu/packages/crates-io.scm (rust-wasmtime-component-util-18): New
variable.

Change-Id: I361b38cfb2a5d08549a2d4fea0d7f51b50386984
---
 gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bb9f658c6b..92230a1dbc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -78521,6 +78521,26 @@  (define-public rust-wasmprinter-0.2
 WebAssembly binary format to the text format.")
     (license license:asl2.0))) ;; With the LLVM exception.
 
+(define-public rust-wasmtime-component-util-18
+  (package
+    (name "rust-wasmtime-component-util")
+    (version "18.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "wasmtime-component-util" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0xr7ypmva710b4yrply4g84262hj431kpa0djnry0zh2k3nf5sl1"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t))
+    (home-page "https://github.com/bytecodealliance/wasmtime")
+    (synopsis "Support code for the WebAssembly component model in Wasmtime")
+    (description "This package provides a library with utility types and
+functions to support the component model in Wasmtime.")
+    (license license:asl2.0))) ;; With the LLVM exception.
+
 (define-public rust-wast-201
   (package
     (name "rust-wast")