diff mbox series

[bug#70146,005/147] gnu: Add rust-anstyle-lossy-1.

Message ID a04441e83eeb12a0ddec4c0e55770f2d27ff263f.1712070305.git.jean@foundation.xyz
State New
Headers show
Series [bug#70146,001/147] gnu: rust-anyhow-1: Update to 1.0.80. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 2, 2024, 4:03 p.m. UTC
* gnu/packages/crates-io.scm (rust-anstyle-lossy-1): New variable.

Change-Id: I830dc37adddc0661468cbbafbffad65e374cc728
---
 gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 38efcd255d..6bd35386b8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1675,6 +1675,27 @@  (define-public rust-anstyle-0.2
      `(#:cargo-development-inputs
        (("rust-lexopt" ,rust-lexopt-0.3))))))
 
+(define-public rust-anstyle-lossy-1
+  (package
+    (name "rust-anstyle-lossy")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "anstyle-lossy" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "10c1cg8vjb7mxwky2xc8j7zdp15i1qvpmd2w6nlsxm6vcx3l9859"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-anstyle" ,rust-anstyle-1))))
+    (home-page "https://github.com/rust-cli/anstyle")
+    (synopsis "Lossy conversion between ANSI Color Codes")
+    (description "This package provides a library to convert colors to and
+from ANSI color codes using the closest color representation.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-anstyle-parse-0.2
   (package
     (name "rust-anstyle-parse")