diff mbox series

[bug#70146,007/147] gnu: Add rust-escape8259-0.5.

Message ID 7f4723e3f01f4cf9d081fa33ae7b1312aec63399.1712070305.git.jean@foundation.xyz
State New
Headers show
Series [bug#70146,001/147] gnu: rust-anyhow-1: Update to 1.0.80. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 2, 2024, 4:03 p.m. UTC
* gnu/packages/crates-io.scm (rust-escape8259-0.5): New variable.

Change-Id: Id0c11cddb5175315ab18c5e4f36077c393f58198
---
 gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index def433bc8c..29efe5a18d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22230,6 +22230,27 @@  (define-public rust-error-code-2
 @code{no_std} environment.")
     (license license:boost1.0)))
 
+(define-public rust-escape8259-0.5
+  (package
+    (name "rust-escape8259")
+    (version "0.5.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "escape8259" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1vjpfnk9fyq6qcc18bq7yfk9ahi2r12lfywr4rwcsvv6wc8ljkxs"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-rustversion" ,rust-rustversion-1))))
+    (home-page "https://github.com/ericseppanen/escape8259")
+    (synopsis "JSON compliant (RFC 8259) string escaping and un-escaping")
+    (description "This package provides a library to escape and un-escape
+strings following the JSON (RFC 8259) standard.")
+    (license license:expat)))
+
 (define-public rust-escaper-0.1
   (package
     (name "rust-escaper")