diff mbox series

[bug#70146,055/147] gnu: Add rust-fallible-iterator-0.3.

Message ID bbb7ceb5ae2a4e6f37b076e109a2caa1d6af5e14.1712070306.git.jean@foundation.xyz
State New
Headers show
Series [bug#70146,001/147] gnu: rust-anyhow-1: Update to 1.0.80. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 2, 2024, 4:04 p.m. UTC
* gnu/packages/crates-io.scm (rust-fallible-iterator-0.3): New variable.
(rust-fallible-iterator-0.2): Inherit from rust-fallible-iterator-0.3.

Change-Id: I7e12549c372c7ca33a7d768a67f1892a075dede2
---
 gnu/packages/crates-io.scm | 34 +++++++++++++++++++++++++---------
 1 file changed, 25 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8196c8f009..65f1b52e6b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22904,8 +22904,32 @@  (define-public rust-failure-derive-0.1
     (description "Derives for the failure crate.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-fallible-iterator-0.3
+  (package
+    (name "rust-fallible-iterator")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "fallible-iterator" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0ja6l56yka5vn4y4pk6hn88z0bpny7a8k1919aqjzp0j1yhy9k1a"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t))
+    (home-page "https://github.com/sfackler/rust-fallible-iterator")
+    (synopsis "Fallible iterator traits")
+    (description "If the @code{std} or @code{alloc} features are enabled, this
+crate provides implementations for @code{Box}, @code{Vec}, @code{BTreeMap}, and
+@code{BTreeSet}.  If the @code{std} feature is enabled, this crate additionally
+provides implementations for @code{HashMap} and @code{HashSet}.")
+    (license (list license:expat
+                   license:asl2.0))))
+
 (define-public rust-fallible-iterator-0.2
   (package
+    (inherit rust-fallible-iterator-0.3)
     (name "rust-fallible-iterator")
     (version "0.2.0")
     (source
@@ -22916,15 +22940,7 @@  (define-public rust-fallible-iterator-0.2
         (sha256
          (base32
           "1xq759lsr8gqss7hva42azn3whgrbrs2sd9xpn92c5ickxm1fhs4"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/sfackler/rust-fallible-iterator")
-    (synopsis "Fallible iterator traits")
-    (description "If the @code{std} or @code{alloc} features are enabled, this
-crate provides implementations for @code{Box}, @code{Vec}, @code{BTreeMap}, and
-@code{BTreeSet}.  If the @code{std} feature is enabled, this crate additionally
-provides implementations for @code{HashMap} and @code{HashSet}.")
-    (license (list license:asl2.0
-                   license:expat))))
+    (arguments `())))
 
 (define-public rust-fallible-streaming-iterator-0.1
   (package