diff mbox series

[bug#70146,018/147] gnu: Add rust-heck-0.5.

Message ID 40dddac6160bad659e168537daaacbdaf5c61fc7.1712070305.git.jean@foundation.xyz
State New
Headers show
Series [bug#70146,001/147] gnu: rust-anyhow-1: Update to 1.0.80. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 2, 2024, 4:03 p.m. UTC
* gnu/packages/crates-io.scm (rust-heck-0.5): New variable.
(rust-heck-0.4): Inherit from rust-heck-0.5.

Change-Id: I76745290d90f2e7a64fb54e05fe4ec56cd6caa0d
---
 gnu/packages/crates-io.scm | 22 +++++++++++++++++++---
 1 file changed, 19 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fe9d225197..6bc3c34ced 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -28532,17 +28532,17 @@  (define-public rust-heapsize-plugin-0.1
 total runtime size of an object on the heap")
     (license license:mpl2.0)))
 
-(define-public rust-heck-0.4
+(define-public rust-heck-0.5
   (package
     (name "rust-heck")
-    (version "0.4.1")
+    (version "0.5.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "heck" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1a7mqsnycv5z4z5vnv1k34548jzmc0ajic7c1j8jsaspnhw5ql4m"))))
+        (base32 "1sjmpsdl8czyh9ywl3qcsfsq9a307dg4ni2vnlwgnzzqhc4y0113"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
@@ -28556,6 +28556,22 @@  (define-public rust-heck-0.4
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-heck-0.4
+  (package
+    (inherit rust-heck-0.5)
+    (name "rust-heck")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "heck" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1a7mqsnycv5z4z5vnv1k34548jzmc0ajic7c1j8jsaspnhw5ql4m"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-unicode-segmentation" ,rust-unicode-segmentation-1))))))
+
 (define-public rust-heck-0.3
   (package
     (inherit rust-heck-0.4)