diff mbox series

[bug#70146,084/147] gnu: Add rust-wasmtime-component-macro-18.

Message ID 526a1e729267d26155667a08e0df402417338e33.1712070307.git.jean@foundation.xyz
State New
Headers show
Series [bug#70146,001/147] gnu: rust-anyhow-1: Update to 1.0.80. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 2, 2024, 4:04 p.m. UTC
* gnu/packages/crates-io.scm (rust-wasmtime-component-macro-18): New
variable.

Change-Id: I1f4ec6c5023b198e518d82a0a90f255d04094ba0
---
 gnu/packages/crates-io.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3bbfef0db0..c62d6fb6b4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -78623,6 +78623,34 @@  (define-public rust-wasmtime-component-util-18
 functions to support the component model in Wasmtime.")
     (license license:asl2.0))) ;; With the LLVM exception.
 
+(define-public rust-wasmtime-component-macro-18
+  (package
+    (name "rust-wasmtime-component-macro")
+    (version "18.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "wasmtime-component-macro" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0xp3pmlzlk137h7y6dldnpjbcv7hk5if9h2jk1nfqr8mag08cdvx"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-anyhow" ,rust-anyhow-1)
+        ("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-2)
+        ("rust-wasmtime-component-util" ,rust-wasmtime-component-util-18)
+        ("rust-wasmtime-wit-bindgen" ,rust-wasmtime-wit-bindgen-18)
+        ("rust-wit-parser" ,rust-wit-parser-0.13))))
+    (home-page "https://github.com/bytecodealliance/wasmtime")
+    (synopsis "Generate WebAssembly component interface")
+    (description "This package provides a library with procedural macros to
+generate WebAssembly component interface types from Rust types.")
+    (license license:asl2.0))) ;; With LLVM exception.
+
 (define-public rust-wasmtime-environ-18
   (package
     (name "rust-wasmtime-environ")