diff mbox series

[bug#70146,072/147] gnu: Add rust-ruzstd-0.5.

Message ID dcc7d1b5f68b744cfc3b39909a97d54952cac3f3.1712070307.git.jean@foundation.xyz
State New
Headers show
Series [bug#70146,001/147] gnu: rust-anyhow-1: Update to 1.0.80. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 2, 2024, 4:04 p.m. UTC
* gnu/packages/crates-io.scm (rust-ruzstd-0.5): New variable.
(rust-ruzstd-0.4): Inherit from rust-ruzstd-0.5.

Change-Id: I99765f3166883c07f04f304cd0a90f56f1d476d2
---
 gnu/packages/crates-io.scm | 39 ++++++++++++++++++++++++++++++++++----
 1 file changed, 35 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f3ffddca6c..9e5882bdba 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -58728,17 +58728,17 @@  (define-public rust-rustyline-derive-0.3
        (("rust-quote" ,rust-quote-1)
         ("rust-syn" ,rust-syn-1))))))
 
-(define-public rust-ruzstd-0.4
+(define-public rust-ruzstd-0.5
   (package
     (name "rust-ruzstd")
-    (version "0.4.0")
+    (version "0.5.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "ruzstd" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1p4ghqzkq36dy1x1ijnk7jmml4wi3v9bkfzlbm2hsnkiz6wglgxc"))))
+        (base32 "0ga8jciw7ka3mxrzl39skmsbdslajghzglcil10g0z4rh65fpi2q"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-test-flags
@@ -58754,7 +58754,7 @@  (define-public rust-ruzstd-0.4
          "--skip=tests::test_specific_file"
          "--skip=tests::test_streaming")
        #:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
-                       ("rust-thiserror-core" ,rust-thiserror-core-1)
+                       ("rust-derive-more" ,rust-derive-more-0.99)
                        ("rust-twox-hash" ,rust-twox-hash-1))
        #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.3)
                                    ("rust-rand" ,rust-rand-0.8))))
@@ -58764,6 +58764,37 @@  (define-public rust-ruzstd-0.4
      "This package provides a decoder for the zstd compression format.")
     (license license:expat)))
 
+(define-public rust-ruzstd-0.4
+  (package
+    (inherit rust-ruzstd-0.5)
+    (name "rust-ruzstd")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ruzstd" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1p4ghqzkq36dy1x1ijnk7jmml4wi3v9bkfzlbm2hsnkiz6wglgxc"))))
+    (arguments
+     `(#:cargo-test-flags
+       '("--release" "--"
+         ;; not all files included
+         "--skip=tests::decode_corpus::test_decode_corpus_files"
+         "--skip=tests::dict_test::test_dict_decoding"
+         "--skip=tests::fuzz_regressions::test_all_artifacts"
+         "--skip=tests::test_block_header_reading"
+         "--skip=tests::test_decode_from_to"
+         "--skip=tests::test_frame_decoder"
+         "--skip=tests::test_frame_header_reading"
+         "--skip=tests::test_specific_file"
+         "--skip=tests::test_streaming")
+       #:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+                       ("rust-thiserror-core" ,rust-thiserror-core-1)
+                       ("rust-twox-hash" ,rust-twox-hash-1))
+       #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.3)
+                                   ("rust-rand" ,rust-rand-0.8))))))
+
 (define-public rust-rkyv-0.7
   (package
     (name "rust-rkyv")