diff mbox series

[bug#70146,091/147] gnu: Add rust-wasmtime-jit-icache-coherence-18.

Message ID 484c56ac2c45135c319c8ba7ed70f28b1a33cc8c.1712070308.git.jean@foundation.xyz
State New
Headers show
Series [bug#70146,001/147] gnu: rust-anyhow-1: Update to 1.0.80. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 2, 2024, 4:04 p.m. UTC
* gnu/packages/crates-io.scm (rust-wasmtime-jit-icache-coherence-18):
New variable.

Change-Id: I6c5a2b409175b94a0f4b957d2edf26a06bed430d
---
 gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ad8dd0b84b..00c8731b18 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -78831,6 +78831,29 @@  (define-public rust-wasmtime-jit-debug-18
     (description "JIT debug interfaces support for Wasmtime")
     (license license:asl2.0))) ;; With LLVM exception.
 
+(define-public rust-wasmtime-jit-icache-coherence-18
+  (package
+    (name "rust-wasmtime-jit-icache-coherence")
+    (version "18.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "wasmtime-jit-icache-coherence" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1wvd5sf79cshgrf45z7r94c2xmvh6sm58sr268mn7d49a1h38rl6"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-windows-sys" ,rust-windows-sys-0.52))))
+    (home-page "https://github.com/bytecodealliance/wasmtime")
+    (synopsis "JIT instruction cache maintenance")
+    (description "This package provides a library with utilities for JIT
+instruction cache maintenance")
+    (license license:asl2.0))) ;; With LLVM exception.
+
 (define-public rust-wasmtime-types-18
   (package
     (name "rust-wasmtime-types")