diff mbox series

[bug#70146,002/147] gnu: Add rust-clap-lex-0.7.

Message ID 43f3250351c50c2c79827edd911c03fc5722354e.1712070305.git.jean@foundation.xyz
State New
Headers show
Series [bug#70146,001/147] gnu: rust-anyhow-1: Update to 1.0.80. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 2, 2024, 4:03 p.m. UTC
* gnu/packages/crates-io.scm (rust-clap-lex-0.7): New variable.
(rust-clap-lex-0.6): Inherit from rust-clap-lex-0.7.

Change-Id: I1c7f695a4356fb72d2f9f1b9cc8a42949ffa0b26
---
 gnu/packages/crates-io.scm | 19 ++++++++++++++++---
 1 file changed, 16 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 061d3388a6..d8504eb396 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11617,17 +11617,17 @@  (define-public rust-clap-complete-fig-3
 with Clap to generate Fig completion scripts.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-clap-lex-0.6
+(define-public rust-clap-lex-0.7
   (package
     (name "rust-clap-lex")
-    (version "0.6.0")
+    (version "0.7.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "clap_lex" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1l8bragdvim7mva9flvd159dskn2bdkpl0jqrr41wnjfn8pcfbvh"))))
+        (base32 "1kh1sckgq71kay2rrr149pl9gbsrvyccsq6xm5xpnq0cxnyqzk4q"))))
     (build-system cargo-build-system)
     (home-page "https://github.com/clap-rs/clap/tree/master/clap_lex")
     (synopsis "Command line parser for Clap")
@@ -11638,6 +11638,19 @@  (define-public rust-clap-lex-0.6
     ;; The user can choose either license.
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-clap-lex-0.6
+  (package
+    (inherit rust-clap-lex-0.7)
+    (name "rust-clap-lex")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "clap_lex" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1l8bragdvim7mva9flvd159dskn2bdkpl0jqrr41wnjfn8pcfbvh"))))))
+
 (define-public rust-clap-lex-0.5
   (package
     (inherit rust-clap-lex-0.6)