diff mbox series

[bug#70146,132/147] gnu: Add rust-smol-2.

Message ID b0d65352169ca12f58b7228fd27dceca5fa0e2b5.1712070309.git.jean@foundation.xyz
State New
Headers show
Series [bug#70146,001/147] gnu: rust-anyhow-1: Update to 1.0.80. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 2, 2024, 4:05 p.m. UTC
* gnu/packages/crates-io.scm (rust-smol-2): New variable.
(rust-smol-1): Inherit from rust-smol-2.

Change-Id: I101ad11c1b2bfdc86aad96a5f5c6cdfffc6bb1c4
---
 gnu/packages/crates-io.scm | 37 +++++++++++++++++++++++++++++++------
 1 file changed, 31 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4cfcb13fd4..2a378599d6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -64338,8 +64338,38 @@  (define-public rust-smawk-0.3
 monotone matrix.")
     (license license:expat)))
 
+(define-public rust-smol-2
+  (package
+    (name "rust-smol")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "smol" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1bbws2bsp00fd5x6k23ja13p158vk76s2adaqxdgh7p5b6936dg6"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-async-channel" ,rust-async-channel-2)
+        ("rust-async-executor" ,rust-async-executor-1)
+        ("rust-async-fs" ,rust-async-fs-2)
+        ("rust-async-io" ,rust-async-io-2)
+        ("rust-async-lock" ,rust-async-lock-3)
+        ("rust-async-net" ,rust-async-net-2)
+        ("rust-async-process" ,rust-async-process-2)
+        ("rust-blocking" ,rust-blocking-1)
+        ("rust-futures-lite" ,rust-futures-lite-2))))
+    (home-page "https://github.com/smol-rs/smol")
+    (synopsis "Small and fast async runtime")
+    (description "This package provides a small and fast async runtime.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-smol-1
   (package
+    (inherit rust-smol-2)
     (name "rust-smol")
     (version "1.2.5")
     (source
@@ -64349,7 +64379,6 @@  (define-public rust-smol-1
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "1r45zng0hymqx1kb2dmxkapbin7f9rhgrdcssz0q7rzka59kpkw5"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
@@ -64362,11 +64391,7 @@  (define-public rust-smol-1
         ("rust-async-process" ,rust-async-process-1)
         ("rust-blocking" ,rust-blocking-1)
         ("rust-futures-lite" ,rust-futures-lite-1)
-        ("rust-once-cell" ,rust-once-cell-1))))
-    (home-page "https://github.com/stjepang/smol")
-    (synopsis "Small and fast async runtime")
-    (description "This package provides a small and fast async runtime.")
-    (license (list license:asl2.0 license:expat))))
+        ("rust-once-cell" ,rust-once-cell-1))))))
 
 (define-public rust-smol-0.1
   (package