diff mbox series

[bug#70146,080/147] gnu: Add rust-fxprof-processed-profile-0.6.

Message ID c303558f703c695f3ad0db2819e9abfb3fe378f6.1712070307.git.jean@foundation.xyz
State New
Headers show
Series [bug#70146,001/147] gnu: rust-anyhow-1: Update to 1.0.80. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 2, 2024, 4:04 p.m. UTC
* gnu/packages/crates-io.scm (rust-fxprof-processed-profile-0.6): New
variable.

Change-Id: Ic227680fdb09d6e015d221dbd4c70f59e815fd1d
---
 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 99ff1c153c..5639de54e9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26458,6 +26458,31 @@  (define-public rust-fxhash-0.2
 derived from an internal hasher used in FireFox and Rustc.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-fxprof-processed-profile-0.6
+  (package
+    (name "rust-fxprof-processed-profile")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "fxprof-processed-profile" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1ggsn3im2bfcnxic0jzk00qgiacfrg2as6i4d8kj87kzxl52rl97"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-bitflags" ,rust-bitflags-2)
+                       ("rust-debugid" ,rust-debugid-0.8)
+                       ("rust-fxhash" ,rust-fxhash-0.2)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/mstange/samply/")
+    (synopsis "Create profiles in the Firefox Profiler's processed format")
+    (description "This package provides a library to create profiles in the
+Firefox Profiler's processed profile JSON format.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-gag-0.1
   (package
     (name "rust-gag")