diff mbox series

[bug#67963,v2,23/37] gnu: Add perl-user-identity.

Message ID e2e3885be07a5da0fd1a322b17b217051df8e5a2.1705443195.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#67963,v2,01/37] gnu: perl.scm: Fix indentation (no functional changes). | expand

Commit Message

Felix Lechner Jan. 16, 2024, 10:13 p.m. UTC
* gnu/packages/perl.scm (perl-user-identity): New variable.

Change-Id: Icd6f46056b7da4a65b112dfefab7ca2c40176152
---
 gnu/packages/perl.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e8302011b6..ec02b25f8c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -12870,6 +12870,32 @@  (define-public perl-time-warp
 developers control over the measurement of time.")
     (license license:perl-license)))
 
+(define-public perl-user-identity
+  (package
+    (name "perl-user-identity")
+    (version "1.02")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/M/MA/MARKOV/User-Identity-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "16dq7s8qjc1z6r094h7ak5796ip6hryb05a1y31nb317ypksw91v"))))
+    (build-system perl-build-system)
+    (propagated-inputs (list perl-hash-ordered))
+    (home-page "https://metacpan.org/release/User-Identity")
+    (synopsis "Collect information about a user")
+    (description "The User-Identity distribution is created to maintain a set
+of informational objects which are related to one user.  The module tries to
+be smart providing defaults, conversions and often required combinations.
+
+The identities are not implemented with any kind of storage, and can
+therefore be created by any simple or complex Perl program.  That way, the
+data structures are more flexible than an XML file.  For instance, you can
+decide to store the data with Data::Dumper, Storable, DBI, AddressBook or
+whatever.")
+    (license license:perl-license)))
+
 (define-public perl-regexp-pattern
   (package
     (name "perl-regexp-pattern")