diff mbox series

[bug#67963,v2,09/37] gnu: Add perl-datetime-format-mysql.

Message ID 0ddc99d91917b763894ddb808024de3883c2aa3b.1705443194.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#67963,v2,01/37] gnu: perl.scm: Fix indentation (no functional changes). | expand

Commit Message

Felix Lechner Jan. 16, 2024, 10:12 p.m. UTC
* gnu/packages/perl.scm (perl-datetime-format-mysql): New variable.

Change-Id: I0ecaa411b3e8f5cd003b3abc9e79d3b552c8e586
---
 gnu/packages/perl.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a60841bb7c..e04903280a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3520,6 +3520,31 @@  (define-public perl-datetime-format-iso8601
 extension that parses almost all ISO8601 date and time formats.")
     (license license:perl-license)))
 
+(define-public perl-datetime-format-mysql
+  (package
+    (name "perl-datetime-format-mysql")
+    (version "0.08")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/X/XM/XMIKEW/DateTime-Format-MySQL-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "1s5r4b8n749gf4b49i1svkfh5aawriqqwsid9lsmwrc4hplp1jqr"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build))
+    (propagated-inputs (list perl-datetime
+                             perl-datetime-format-builder))
+    (home-page "https://metacpan.org/release/DateTime-Format-MySQL")
+    (synopsis "Parse and format MySQL dates and times")
+    (description "This module understands the formats used by MySQL for
+its DATE, DATETIME, TIME, and TIMESTAMP data types.  It can be used to
+parse these formats in order to create DateTime objects, and it can
+take a DateTime object and produce a string representing it in the
+MySQL format.")
+    (license license:perl-license)))
+
 (define-public perl-datetime-format-natural
   (package
     (name "perl-datetime-format-natural")