diff mbox series

[bug#67963,v2,04/37] gnu: Add perl-devel-confess.

Message ID 41ef85816f672c4b9484fbdd24f5ed7544e03db8.1705443194.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#67963,v2,01/37] gnu: perl.scm: Fix indentation (no functional changes). | expand

Commit Message

Felix Lechner Jan. 16, 2024, 10:12 p.m. UTC
* gnu/packages/perl.scm (perl-devel-confess): New variable.

Change-Id: I8973759cb75e4c7d22096238a0a06d583d082813
---
 gnu/packages/perl.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 033c9900ce..c59f53139b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3795,6 +3795,25 @@  (define-public perl-devel-checkcompiler
 you can tell it to compile a C source file with optional linker flags.")
     (license (package-license perl))))
 
+(define-public perl-devel-confess
+  (package
+    (name "perl-devel-confess")
+    (version "0.009004")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/Devel-Confess-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "1pbl38lkvmz97ddy26sg7ynsrspmf4phd0pk2ac95xjw6kdh3im8"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/Devel-Confess")
+    (synopsis "Include stack traces on all warnings and errors")
+    (description "This module is meant as a debugging aid.  It can be used to make a
+script complain loudly with stack backtraces when warning or dying.  Unlike modules
+such as Carp::Always, stack traces are also included when exceptions are thrown.")
+    (license license:perl-license)))
+
 (define-public perl-devel-cycle
   (package
     (name "perl-devel-cycle")