diff mbox series

[bug#67963,v2,27/37] gnu: Add perl-text-iconv.

Message ID 3acbf3e3d04f340906c5bda0e367a64a44108060.1705443195.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#67963,v2,01/37] gnu: perl.scm: Fix indentation (no functional changes). | expand

Commit Message

Felix Lechner Jan. 16, 2024, 10:13 p.m. UTC
* gnu/packages/perl.scm (perl-text-iconv): New variable.

Change-Id: I7abfdee84d8590175f4d3282cb6e9f9157504251
---
 gnu/packages/perl.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 1e1b5f82bf..921d8be1c2 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11157,6 +11157,26 @@  (define-public perl-text-haml
 @url{http://haml.info/docs/yardoc/file.REFERENCE.html} specification.")
     (license license:artistic2.0)))
 
+(define-public perl-text-iconv
+  (package
+    (name "perl-text-iconv")
+    (version "1.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/M/MP/MPIOTR/Text-Iconv-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "1hymsbkjkl43wg74p7hgpyjl8yx1chc9g25spj9l7lq9wzavg02v"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/Text-Iconv")
+    (synopsis "Perl interface to iconv() codeset conversion function")
+    (description "The Text::Iconv module provides a Perl interface to the
+@code{iconv()} function as defined by the Single UNIX Specification.  The
+@code{convert()} method converts the encoding of characters in the input
+string from the @code{fromcode} codeset to the @code{tocode} codeset.")
+    (license license:asl2.0)))
+
 (define-public perl-text-neattemplate
   (package
     (name "perl-text-neattemplate")